The Roskamp Institute - EMail to Apple Users Fails – Incident details
Experiencing partial outage
EMail to Apple Users Fails
Resolved
Degraded performance
Started 9 months agoLasted about 1 hour
Affected
External Services
Degraded performance from 7:11 PM to 8:09 PM
Microsoft 365
Degraded performance from 7:11 PM to 8:09 PM
Updates
Resolved
Resolved
This incident has been resolved. Emails should be delivered now.
Identified
Identified
We have identified an issue with outgoing mail to @icloud, @me, and @mac.com email accounts. At this time there is no workaround for the issue as the receiving end is rejecting the mail. We have made contact with Apple and are working on a solution.